Back to overview
Degraded

Whatfix Web Platform Performance Degradation

Mar 30 at 10:31am UTC
Affected services
DAP (Web/ Desktop) - North America - Dashboard

Resolved
Mar 30 at 10:55am UTC

This incident has been resolved.

Updated
Mar 30 at 10:35am UTC

A fix has been implemented and we are monitoring the results.

Created
Mar 30 at 10:31am UTC

We are currently investigating this issue.