Back to overview
Degraded

Whatfix Web Platform Performance Degradation

Nov 10 at 02:18pm UTC
Affected services
DAP (Web/ Desktop) - North America - Studio
DAP (Web/ Desktop) - North America - Dashboard

Resolved
Nov 10 at 03:34pm UTC

This incident has been resolved.

Updated
Nov 10 at 03:03pm UTC

We are continuing to monitor for any further issues.

Updated
Nov 10 at 02:59pm UTC

A fix has been implemented and we are monitoring the results.

Updated
Nov 10 at 02:43pm UTC

We are continuing to investigate this issue.

Created
Nov 10 at 02:18pm UTC

The site is currently experiencing a higher-than-normal amount of load which may be causing pages to be slow or unresponsive. We are investigating the cause and will provide an update as soon as possible.