Back to overview
Degraded

Whatfix Web Platform Performance Degradation

Feb 28 at 09:30am UTC
Affected services
DAP (Web/ Desktop) - EU - Dashboard

Resolved
Feb 28 at 09:33am UTC

This incident has been resolved.

Updated
Feb 28 at 09:33am UTC

We are continuing to investigate this issue.

Created
Feb 28 at 09:30am UTC

We are currently investigating this issue.