Back to overview
Degraded

Dashboard is unavailable

Mar 20, 2026 at 03:05pm UTC
Affected services
DAP (Web) - North America - End User Experience
DAP (Web/ Desktop) - North America - Dashboard
DAP (Web) - North America - Multi Format Outputs
DAP (Web) - North America - Push to Production Service
DAP (Mobile) - North America - End User Experience

Resolved
Mar 20, 2026 at 03:43pm UTC

The issue has been identified and resolved, and services are now operating normally. We are implementing additional improvements to enhance system stability and prevent similar occurrences in the future.

Created
Mar 20, 2026 at 03:05pm UTC

We are currently experiencing an outage affecting the dashboard. Our team is actively investigating the issue and working towards a resolution. We will provide updates as more information becomes available.