Back to overview
Degraded
Dashboard is unavailable
Mar 27, 2026 at 12:50pm UTC
Affected services
DAP (Web/ Desktop) - North America - Studio
DAP (Web/ Desktop) - North America - Dashboard
Resolved
Mar 27, 2026 at 03:24pm UTC
All services are up and running.
Affected services
Created
Mar 27, 2026 at 12:50pm UTC
Dashboard is currently unavailable, the issue is related to our internal services. We're working on fixing the issue and dashboard will be available again very soon.
Affected services