Back to overview
Degraded

Popup creation and updates are currently degraded

Apr 22, 2026 at 5:50pm UTC
Affected services
DAP (Web/ Desktop) - North America - Studio
DAP (Web/ Desktop) - North America - Dashboard
DAP (Web/ Desktop) - EU - Studio
DAP (Web/ Desktop) - EU - Dashboard

Resolved
Apr 22, 2026 at 7:56pm UTC

The issue causing the popup close (“X”) button to appear incorrectly at the top-right corner of the application has been resolved. Popup creation and update functionality have been restored.

Created
Apr 22, 2026 at 5:50pm UTC

Impact: In Popup, the “X” (close button) is incorrectly positioned at the top-right corner of the application instead of within the popup, which may cause confusion for end users.

Current Mitigation: Popup creation and updates have been temporarily blocked to prevent further impact.

Any popups created or updated between April 21, 02:35 UTC and April 22, 17:50 UTC are affected. We are actively working on fixing the impacted popups. The team is investigating the root cause and implementing a fix.