Dashboard and monitor are down
Resolved
May 26, 2026 at 2:53pm UTC
The elevated traffic observed on a subset of APIs has now reduced, and the issue has been mitigated. Services are operating normally, and we will continue monitoring system stability closely.
Affected services
Created
May 26, 2026 at 12:41pm UTC
We are currently experiencing elevated traffic on a subset of APIs, which is causing intermittent failures and increased response times for some users. Our engineering team is actively investigating and working to stabilize the affected services.
Affected services