Back to overview
Maintenance

Scheduled Maintenance: Disaster Recovery (DR) Exercise

Jun 21, 2026 at 5:30am UTC  –  Jun 21, 2026 at 8:37am UTC
Affected services
DAP (Web) - North America - End User Experience
DAP (Web/ Desktop) - North America - Studio
DAP (Web/ Desktop) - North America - Dashboard
DAP (Web) - North America - Multi Format Outputs
DAP (Web) - North America - Push to Production Service
DAP (Web) - North America - Survey Service
DAP (Mobile) - North America - Content Authoring Services
DAP (Mobile) - North America - End User Experience
DAP (Desktop) - North America - End User Experience
DAP (Enterprise) - North America
PA - North America - Analytics Ingestion Service
Mirror - North America - Mirror Service

Resolved
Jun 21, 2026 at 8:37am UTC

The scheduled maintenance has been completed.

Updated
Jun 21, 2026 at 8:37am UTC

Maintenance ended

Created
Jun 21, 2026 at 5:30am UTC

Scheduled Maintenance: Disaster Recovery (DR) Exercise

To comply with our compliance standards and ensure maximum business continuity, our engineering team will conduct a scheduled Disaster Recovery (DR) and live region failover exercise.

Maintenance Window :
Date: Sunday, 21 June 2026
Time: 11:00 AM IST – 11:59 PM IST (05:30 UTC – 18:29 UTC)

As part of the exercise, production traffic will be progressively routed through our disaster recovery environment to validate live region failover and recovery processes.

Expected Impact:
Services will remain fully operational, and no customer impact is expected. In the unlikely event that customers experience elevated latency or brief service interruptions, any such disruption is expected to be brief and transitory.

Our engineering teams will monitor the exercise throughout the maintenance window and post updates on the status page if there are any changes to the expected service experience, as well as when the exercise has been completed.

Thank you for your patience and understanding.
Team Whatfix