Back to overview
Downtime

Whatfix Studio and Dashboard temporarily unavailable during maintenance

May 25 at 01:50pm UTC
Affected services
DAP (Web) - North America - Studio
DAP (Web/ Desktop) - North America - Dashboard

Resolved
May 25 at 02:03pm UTC

The Whatfix Studio and Dashboard are back online. All services are restored now.

Created
May 25 at 01:50pm UTC

Whatfix Studio and Dashboard experienced reliability issues during the maintenance window. This has been attributed to the actions taken during the Disaster Recovery exercise.