Back to overview
Degraded

Intermittent loading issue on dashboard

May 14 at 01:33pm UTC
Affected services
DAP (Web/ Desktop) - North America - Studio
DAP (Web/ Desktop) - North America - Dashboard

Resolved
May 14 at 02:32pm UTC

Team has identified the issue and have provided a fix to it. We are confirming that all functionalities are back online.

Created
May 14 at 01:33pm UTC

We are currently experiencing an ongoing issue where the dashboard is not loading for North America. Our team is investigating the root cause.